CVEvulnerability
CVE-2023-28107
4.9 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2023-03-17
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 4.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:N/A:H
- CVSS 3.1 ([email protected])
- 4.9 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-770
Description
Discourse is an open-source discussion platform. Prior to version 3.0.2 of the `stable` branch and version 3.1.0.beta3 of the `beta` and `tests-passed` branches, a user logged as an administrator can request backups multiple times, which will eat up all the connections to the DB. If this is done on a site using multisite, then it can affect the whole cluster. The vulnerability is patched in version 3.0.2 of the `stable` branch and version 3.1.0.beta3 of the `beta` and `tests-passed` branches. There are no known workarounds.
Affected configurations
• discourse discourse (<= 3.0.1)
• discourse discourse (< 3.1.0)
• discourse discourse 3.1.0
Related
Weakness · CWE (1)
- CWE-770 Allocation of Resources Without Limits or Throttling weakness
References
- https://github.com/discourse/discourse/commit/0bd64788d2b4680c04fbef76314a24884d65fed9 Patch
- https://github.com/discourse/discourse/commit/78a3efa7104eed6dd3ed7a06a71e2705337d9e61 Patch
- https://github.com/discourse/discourse/pull/20700 Patch
- https://github.com/discourse/discourse/pull/20701 Patch
- https://github.com/discourse/discourse/security/advisories/GHSA-cp7c-fm4c-6xxx Vendor Advisory
- https://github.com/discourse/discourse/commit/0bd64788d2b4680c04fbef76314a24884d65fed9 Patch
- https://github.com/discourse/discourse/commit/78a3efa7104eed6dd3ed7a06a71e2705337d9e61 Patch
- https://github.com/discourse/discourse/pull/20700 Patch
- https://github.com/discourse/discourse/pull/20701 Patch
- https://github.com/discourse/discourse/security/advisories/GHSA-cp7c-fm4c-6xxx Vendor Advisory