CVEvulnerability
CVE-2023-28112
8.1 HIGH
Official page ↗
- Status
- Modified
- Published
- 2023-03-17
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 5.9 MEDIUM — CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:L/A:N
- CVSS 3.1 ([email protected])
- 8.1 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- Weaknesses
- CWE-918
Description
Discourse is an open-source discussion platform. Prior to version 3.1.0.beta3 of the `beta` and `tests-passed` branches, some user provided URLs were being passed to FastImage without SSRF protection. Insufficient protections could enable attackers to trigger outbound network connections from the Discourse server to private IP addresses. This affects any site running the `tests-passed` or `beta` branches versions 3.1.0.beta2 and prior. This issue is patched in version 3.1.0.beta3 of the `beta` and `tests-passed` branches. There are no known workarounds.
Affected configurations
• discourse discourse (< 3.1.0)
• discourse discourse (<= 3.1.0)
• discourse discourse 3.1.0
Related
Weakness · CWE (1)
- CWE-918 Server-Side Request Forgery weakness
References
- https://github.com/discourse/discourse/commit/39c2f63b35d90ebaf67b9604cf1d424e5984203c Patch
- https://github.com/discourse/discourse/pull/20710 Patch
- https://github.com/discourse/discourse/security/advisories/GHSA-9897-x229-55gh Vendor Advisory
- https://github.com/discourse/discourse/commit/39c2f63b35d90ebaf67b9604cf1d424e5984203c Patch
- https://github.com/discourse/discourse/pull/20710 Patch
- https://github.com/discourse/discourse/security/advisories/GHSA-9897-x229-55gh Vendor Advisory