CVEvulnerability
CVE-2023-2905
8.8 HIGH
Official page ↗
- Status
- Modified
- Published
- 2023-08-09
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.8 HIGH — CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-122, CWE-787
Description
Due to a failure in validating the length of a provided MQTT_CMD_PUBLISH parsed message with a variable length header, Cesanta Mongoose, an embeddable web server, version 7.10 is susceptible to a heap-based buffer overflow vulnerability in the default configuration. Version 7.9 and prior does not appear to be vulnerable. This issue is resolved in version 7.11.
Affected configurations
• cesanta mongoose 7.10
Related
References
- https://github.com/cesanta/mongoose/pull/2274 Patch
- https://github.com/cesanta/mongoose/releases/tag/7.11 Release Notes
- https://takeonme.org/cves/CVE-2023-2905.html Exploit, Patch, Third Party Advisory
- https://github.com/cesanta/mongoose/pull/2274 Patch
- https://github.com/cesanta/mongoose/releases/tag/7.11 Release Notes
- https://takeonme.org/cves/CVE-2023-2905.html Exploit, Patch, Third Party Advisory