CVEvulnerability
CVE-2023-29216
9.8 CRITICAL
Official page ↗
- Status
- Modified
- Published
- 2023-04-10
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-502
Description
In Apache Linkis <=1.3.1, because the parameters are not
effectively filtered, the attacker uses the MySQL data source and malicious parameters to
configure a new data source to trigger a deserialization vulnerability, eventually leading to
remote code execution.
Versions of Apache Linkis <= 1.3.0 will be affected.
We recommend users upgrade the version of Linkis to version 1.3.2.
Affected configurations
• apache linkis (<= 1.3.1)
Related
Weakness · CWE (1)
- CWE-502 Deserialization of Untrusted Data weakness
References
- http://www.openwall.com/lists/oss-security/2023/04/10/5 Mailing List, Third Party Advisory
- https://lists.apache.org/thread/18vv0m32oy51nzk8tbz13qdl5569y55l Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2023/04/10/5 Mailing List, Third Party Advisory
- https://lists.apache.org/thread/18vv0m32oy51nzk8tbz13qdl5569y55l Mailing List, Vendor Advisory