CVEvulnerability

CVE-2023-30631

7.5 HIGH Published 2023-06-14 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2023-06-14
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-20

Description

Improper Input Validation vulnerability in Apache Software Foundation Apache Traffic Server.  The configuration option proxy.config.http.push_method_enabled didn't function.  However, by default the PUSH method is blocked in the ip_allow configuration file.This issue affects Apache Traffic Server: from 8.0.0 through 9.2.0. 8.x users should upgrade to 8.1.7 or later versions 9.x users should upgrade to 9.2.1 or later versions

Affected configurations

• apache traffic server (>= 8.0.0 < 8.1.7) • apache traffic server (>= 9.0.0 < 9.2.1) • debian debian linux 10.0 • debian debian linux 11.0 • debian debian linux 12.0 • fedoraproject fedora 37 • fedoraproject fedora 38

Related

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References