CVEvulnerability
CVE-2023-3085
6.1 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2023-06-03
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 3.5 LOW — CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
- CVSS 3.1 ([email protected])
- 6.1 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CVSS 2.0 ([email protected])
- 4.0 MEDIUM — AV:N/AC:L/Au:S/C:N/I:P/A:N
- Weaknesses
- CWE-79
Description
A vulnerability, which was classified as problematic, has been found in X-WRT luci up to 22.10_b202303061504. This issue affects the function run_action of the file modules/luci-base/ucode/dispatcher.uc of the component 404 Error Template Handler. The manipulation of the argument request_path leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 22.10_b202303121313 is able to address this issue. The patch is named 24d7da2416b9ab246825c33c213fe939a89b369c. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-230663.
Affected configurations
• x-wrt luci (< 22.10 b202303121313)
Related
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://github.com/x-wrt/luci/commit/24d7da2416b9ab246825c33c213fe939a89b369c Patch
- https://github.com/x-wrt/luci/releases/tag/22.10_b202303121313 Release Notes
- https://vuldb.com/?ctiid.230663 Permissions Required, Third Party Advisory
- https://vuldb.com/?id.230663 Permissions Required, Third Party Advisory
- https://github.com/x-wrt/luci/commit/24d7da2416b9ab246825c33c213fe939a89b369c Patch
- https://github.com/x-wrt/luci/releases/tag/22.10_b202303121313 Release Notes
- https://vuldb.com/?ctiid.230663 Permissions Required, Third Party Advisory
- https://vuldb.com/?id.230663 Permissions Required, Third Party Advisory