CVEvulnerability
CVE-2023-31007
6.5 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2023-07-12
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 0.0 NONE — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:N
- CVSS 3.1 ([email protected])
- 6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
- Weaknesses
- CWE-287
Description
Improper Authentication vulnerability in Apache Software Foundation Apache Pulsar Broker allows a client to stay connected to a broker after authentication data expires if the client connected through the Pulsar Proxy when the broker is configured with authenticateOriginalAuthData=false or if a client connects directly to a broker with a specially crafted connect command when the broker is configured with authenticateOriginalAuthData=false.
This issue affects Apache Pulsar: through 2.9.4, from 2.10.0 through 2.10.3, 2.11.0.
2.9 Pulsar Broker users should upgrade to at least 2.9.5.
2.10 Pulsar Broker users should upgrade to at least 2.10.4.
2.11 Pulsar Broker users should upgrade to at least 2.11.1.
3.0 Pulsar Broker users are unaffected.
Any users running the Pulsar Broker for 2.8.* and earlier should upgrade to one of the above patched versions.
Affected configurations
• apache pulsar (< 2.9.5)
• apache pulsar (>= 2.10.0 <= 2.10.3)
• apache pulsar 2.11.0
Related
Weakness · CWE (1)
- CWE-287 Improper Authentication weakness
References
- https://lists.apache.org/thread/qxn99xxyp0zv6jchjggn3soyo5gvqfxj Mailing List, Vendor Advisory
- https://lists.apache.org/thread/qxn99xxyp0zv6jchjggn3soyo5gvqfxj Mailing List, Vendor Advisory