CVEvulnerability
CVE-2023-31062
9.8 CRITICAL
Official page ↗
- Status
- Modified
- Published
- 2023-05-22
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-269
Description
Improper Privilege Management Vulnerabilities in Apache Software Foundation Apache InLong.This issue affects Apache InLong: from 1.2.0 through 1.6.0. When the attacker has access to a valid (but unprivileged) account, the exploit can be executed using Burp Suite by sending a login
request and following it with a subsequent HTTP request
using the returned cookie.
Users are advised to upgrade to Apache InLong's 1.7.0 or cherry-pick https://github.com/apache/inlong/pull/7836 https://github.com/apache/inlong/pull/7836 to solve it.
Affected configurations
• apache inlong (>= 1.2.0 <= 1.6.0)
Related
Weakness · CWE (1)
- CWE-269 Improper Privilege Management weakness
References
- https://lists.apache.org/thread/btorjbo9o71h22tcvxzy076022hjdzq0 Mailing List, Vendor Advisory
- https://lists.apache.org/thread/btorjbo9o71h22tcvxzy076022hjdzq0 Mailing List, Vendor Advisory