CVEvulnerability
CVE-2023-31098
9.8 CRITICAL
Official page ↗
- Status
- Modified
- Published
- 2023-05-22
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-521
Description
Weak Password Requirements vulnerability in Apache Software Foundation Apache InLong.This issue affects Apache InLong: from 1.1.0 through 1.6.0.
When users change their password to a simple password (with any character or
symbol), attackers can easily guess the user's password and access the account.
Users are advised to upgrade to Apache InLong's 1.7.0 or cherry-pick https://github.com/apache/inlong/pull/7805 https://github.com/apache/inlong/pull/7805 to solve it.
Affected configurations
• apache inlong (>= 1.1.0 <= 1.6.0)
Related
Weakness · CWE (1)
- CWE-521 Weak Password Requirements weakness
References
- https://lists.apache.org/thread/1fvloc3no1gbffzrcsx9ltsg08wr2d1w Mailing List, Vendor Advisory
- https://lists.apache.org/thread/1fvloc3no1gbffzrcsx9ltsg08wr2d1w Mailing List, Vendor Advisory