CVEvulnerability
CVE-2023-32688
7.5 HIGH
Official page ↗
- Status
- Modified
- Published
- 2023-05-27
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 4.9 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-20
Description
parse-server-push-adapter is the official Push Notification adapter for Parse Server. The Parse Server Push Adapter can crash Parse Server due to an invalid push notification payload. This issue has been patched in version 4.1.3.
Affected configurations
• parseplatform parse server push adapter (< 4.1.3)
Related
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://github.com/parse-community/parse-server-push-adapter/pull/217 Patch
- https://github.com/parse-community/parse-server-push-adapter/releases/tag/4.1.3 Release Notes
- https://github.com/parse-community/parse-server-push-adapter/security/advisories/GHSA-mxhg-rvwx-x993 Patch, Vendor Advisory
- https://github.com/parse-community/parse-server-push-adapter/pull/217 Patch
- https://github.com/parse-community/parse-server-push-adapter/releases/tag/4.1.3 Release Notes
- https://github.com/parse-community/parse-server-push-adapter/security/advisories/GHSA-mxhg-rvwx-x993 Patch, Vendor Advisory