CVEvulnerability
CVE-2023-33966
9.8 CRITICAL
Official page ↗
- Status
- Modified
- Published
- 2023-05-31
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.6 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-269, CWE-276
Description
Deno is a runtime for JavaScript and TypeScript. In deno 1.34.0 and deno_runtime 0.114.0, outbound HTTP requests made using the built-in `node:http` or `node:https` modules are incorrectly not checked against the network permission allow list (`--allow-net`). Dependencies relying on these built-in modules are subject to the vulnerability too. Users of Deno versions prior to 1.34.0 are unaffected. Deno Deploy users are unaffected. This problem has been patched in Deno v1.34.1 and deno_runtime 0.114.1 and all users are recommended to update to this version. No workaround is available for this issue.
Affected configurations
• deno deno 1.34.0
• deno deno runtime 0.114.0
Related
References
- https://github.com/denoland/deno/releases/tag/v1.34.1 Release Notes
- https://github.com/denoland/deno/security/advisories/GHSA-vc52-gwm3-8v2f Vendor Advisory
- https://github.com/denoland/deno/releases/tag/v1.34.1 Release Notes
- https://github.com/denoland/deno/security/advisories/GHSA-vc52-gwm3-8v2f Vendor Advisory