CVEvulnerability
CVE-2023-34442
3.3 LOW
Official page ↗
- Status
- Modified
- Published
- 2023-07-10
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 3.3 LOW — CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- Weaknesses
- CWE-200
Description
Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache Software Foundation Apache Camel.This issue affects Apache Camel: from 3.X through <=3.14.8, from 3.18.X through <=3.18.7, from 3.20.X through <= 3.20.5, from 4.X through <= 4.0.0-M3.
Users should upgrade to 3.14.9, 3.18.8, 3.20.6 or 3.21.0 and for users on Camel 4.x update to 4.0.0-M1
Affected configurations
• apache camel (>= 3.0.0 < 3.14.9)
• apache camel (>= 3.18.0 < 3.18.8)
• apache camel (>= 3.20.0 < 3.20.6)
• apache camel 4.0.0
Related
Weakness · CWE (1)
- CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness
References
- https://lists.apache.org/thread/x4vy2hhbltb1xrvy1g6m8hpjgj2k7wgh Mailing List, Vendor Advisory
- https://lists.apache.org/thread/x4vy2hhbltb1xrvy1g6m8hpjgj2k7wgh Mailing List, Vendor Advisory