CVEvulnerability
CVE-2023-35005
6.5 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2023-06-19
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-200
Description
In Apache Airflow, some potentially sensitive values were being shown to the user in certain situations.
This vulnerability is mitigated by the fact configuration is not shown in the UI by default (only if `[webserver] expose_config` is set to `non-sensitive-only`), and not all uncensored values are actually sentitive.
This issue affects Apache Airflow: from 2.5.0 before 2.6.2. Users are recommended to update to version 2.6.2 or later.
Affected configurations
• apache airflow (>= 2.5.0 < 2.6.2)
Related
Weakness · CWE (1)
- CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness
References
- https://github.com/apache/airflow/pull/31788 Patch
- https://github.com/apache/airflow/pull/31820 Issue Tracking
- https://lists.apache.org/thread/o4f2cxh0054m9tlxpb81c1yhylor5gjd Mailing List, Vendor Advisory
- https://github.com/apache/airflow/pull/31788 Patch
- https://github.com/apache/airflow/pull/31820 Issue Tracking
- https://lists.apache.org/thread/o4f2cxh0054m9tlxpb81c1yhylor5gjd Mailing List, Vendor Advisory