CVEvulnerability
CVE-2023-36468
8.8 HIGH
Official page ↗
- Status
- Modified
- Published
- 2023-06-29
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 9.9 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- CVSS 3.1 ([email protected])
- 8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-459
Description
XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. When an XWiki installation is upgraded and that upgrade contains a fix for a bug in a document, just a new version of that document is added. In some cases, it's still possible to exploit the vulnerability that was fixed in the new version. The severity of this depends on the fixed vulnerability, for the purpose of this advisory take CVE-2022-36100/GHSA-2g5c-228j-p52x as example - it is easily exploitable with just view rights and critical. When XWiki is upgraded from a version before the fix for it (e.g., 14.3) to a version including the fix (e.g., 14.4), the vulnerability can still be reproduced by adding `rev=1.1` to the URL used in the reproduction steps so remote code execution is possible even after upgrading. Therefore, this affects the confidentiality, integrity and availability of the whole XWiki installation. This vulnerability also affects manually added script macros that contained security vulnerabilities that were later fixed by changing the script macro without deleting the versions with the security vulnerability from the history. This vulnerability doesn't affect freshly installed versions of XWiki. Further, this vulnerability doesn't affect content that is only loaded from the current version of a document like the code of wiki macros or UI extensions. This vulnerability has been patched in XWiki 14.10.7 and 15.2RC1 by forcing old revisions to be executed in a restricted mode that disables all script macros. As a workaround, admins can manually delete old revisions of affected documents. A script could be used to identify all installed documents and delete the history for them. However, also manually added and later corrected code may be affected by this vulnerability so it is easy to miss documents.
Affected configurations
• xwiki xwiki (>= 2.0 < 14.10.7)
• xwiki xwiki 15.0
• xwiki xwiki 15.1
Related
Weakness · CWE (1)
- CWE-459 Incomplete Cleanup weakness
References
- https://github.com/xwiki/xwiki-platform/commit/15a6f845d8206b0ae97f37aa092ca43d4f9d6e59 Patch
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-2g5c-228j-p52x Exploit, Vendor Advisory
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-8q9q-r9v2-644m Exploit, Patch, Vendor Advisory
- https://jira.xwiki.org/browse/XWIKI-20594 Exploit, Issue Tracking, Patch, Vendor Advisory
- https://github.com/xwiki/xwiki-platform/commit/15a6f845d8206b0ae97f37aa092ca43d4f9d6e59 Patch
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-2g5c-228j-p52x Exploit, Vendor Advisory
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-8q9q-r9v2-644m Exploit, Patch, Vendor Advisory
- https://jira.xwiki.org/browse/XWIKI-20594 Exploit, Issue Tracking, Patch, Vendor Advisory