CVEvulnerability
CVE-2023-37478
9.8 CRITICAL
Official page ↗
- Status
- Modified
- Published
- 2023-08-01
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-284
Description
pnpm is a package manager. It is possible to construct a tarball that, when installed via npm or parsed by the registry is safe, but when installed via pnpm is malicious, due to how pnpm parses tar archives. This can result in a package that appears safe on the npm registry or when installed via npm being replaced with a compromised or malicious version when installed via pnpm. This issue has been patched in version(s) 7.33.4 and 8.6.8.
Affected configurations
• pnpm pnpm (< 7.33.4)
• pnpm pnpm (>= 8.0.0 < 8.6.8)
Related
Weakness · CWE (1)
- CWE-284 Improper Access Control weakness
References
- https://github.com/pnpm/pnpm/releases/tag/v7.33.4 Release Notes
- https://github.com/pnpm/pnpm/releases/tag/v8.6.8 Release Notes
- https://github.com/pnpm/pnpm/security/advisories/GHSA-5r98-f33j-g8h7 Vendor Advisory
- https://github.com/pnpm/pnpm/releases/tag/v7.33.4 Release Notes
- https://github.com/pnpm/pnpm/releases/tag/v8.6.8 Release Notes
- https://github.com/pnpm/pnpm/security/advisories/GHSA-5r98-f33j-g8h7 Vendor Advisory