CVEvulnerability
CVE-2023-37924
9.8 CRITICAL
Official page ↗
- Status
- Modified
- Published
- 2023-11-22
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-89
Description
Apache Software Foundation Apache Submarine has an SQL injection vulnerability when a user logs in. This issue can result in unauthorized login.
Now we have fixed this issue and now user must have the correct login to access workbench.
This issue affects Apache Submarine: from 0.7.0 before 0.8.0. We recommend that all submarine users with 0.7.0 upgrade to 0.8.0, which not only fixes the issue, supports the oidc authentication mode, but also removes the case of unauthenticated logins.
If using the version lower than 0.8.0 and not want to upgrade, you can try cherry-pick PR https://github.com/apache/submarine/pull/1037 https://github.com/apache/submarine/pull/1054 and rebuild the submarine-server image to fix this.
Affected configurations
• apache submarine (>= 0.7.0 < 0.8.0)
Related
Weakness · CWE (1)
- CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness
References
- https://github.com/apache/submarine/pull/1037 Issue Tracking
- https://issues.apache.org/jira/browse/SUBMARINE-1361 Issue Tracking, Vendor Advisory
- https://lists.apache.org/thread/g99h773vd49n1wyghdq1llv2f83w1b3r Mailing List, Vendor Advisory
- https://github.com/apache/submarine/pull/1037 Issue Tracking
- https://issues.apache.org/jira/browse/SUBMARINE-1361 Issue Tracking, Vendor Advisory
- https://lists.apache.org/thread/g99h773vd49n1wyghdq1llv2f83w1b3r Mailing List, Vendor Advisory