CVEvulnerability
CVE-2023-37941
6.6 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2023-09-06
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 6.6 MEDIUM — CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H
- CVSS 3.1 ([email protected])
- 6.6 MEDIUM — CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-502
Description
If an attacker gains write access to the Apache Superset metadata database, they could persist a specifically crafted Python object that may lead to remote code execution on Superset's web backend.
The Superset metadata db is an 'internal' component that is typically
only accessible directly by the system administrator and the superset
process itself. Gaining access to that database should
be difficult and require significant privileges.
This vulnerability impacts Apache Superset versions 1.5.0 up to and including 2.1.0. Users are recommended to upgrade to version 2.1.1 or later.
Affected configurations
• apache superset (>= 1.5.0 <= 2.1.0)
Related
Weakness · CWE (1)
- CWE-502 Deserialization of Untrusted Data weakness
References
- http://packetstormsecurity.com/files/175094/Apache-Superset-2.0.0-Remote-Code-Execution.html packetstormsecurity.com
- https://lists.apache.org/thread/6qk1zscc06yogxxfgz2bh2bvz6vh9g7h Vendor Advisory
- http://packetstormsecurity.com/files/175094/Apache-Superset-2.0.0-Remote-Code-Execution.html packetstormsecurity.com
- https://lists.apache.org/thread/6qk1zscc06yogxxfgz2bh2bvz6vh9g7h Vendor Advisory