CVEvulnerability
CVE-2023-38495
9.8 CRITICAL
Official page ↗
- Status
- Modified
- Published
- 2023-07-27
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.3 HIGH — CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-20
Description
Crossplane is a framework for building cloud native control planes without needing to write code. In versions prior to 1.11.5, 1.12.3, and 1.13.0, Crossplane's image backend does not validate the byte contents of Crossplane packages. As such, Crossplane does not detect if an attacker has tampered with a Package. The problem has been fixed in 1.11.5, 1.12.3 and 1.13.0. As a workaround, only use images from trusted sources and keep Package editing/creating privileges to administrators only.
Affected configurations
• cncf crossplane (< 1.11.5)
• cncf crossplane (>= 1.12.0 < 1.12.3)
Related
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://github.com/crossplane/crossplane/blob/ac8b24fe739c5d942ea885157148497f196c3dd3/security/ADA-security-audit-23.pdf Exploit, Technical Description, Vendor Advisory
- https://github.com/crossplane/crossplane/security/advisories/GHSA-pj4x-2xr5-w87m Vendor Advisory
- https://github.com/crossplane/crossplane/blob/ac8b24fe739c5d942ea885157148497f196c3dd3/security/ADA-security-audit-23.pdf Exploit, Technical Description, Vendor Advisory
- https://github.com/crossplane/crossplane/security/advisories/GHSA-pj4x-2xr5-w87m Vendor Advisory