CVEvulnerability
CVE-2023-38510
8.1 HIGH
Official page ↗
- Status
- Modified
- Published
- 2023-07-27
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.1 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- CVSS 3.1 ([email protected])
- 8.1 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- Weaknesses
- CWE-862
Description
Tolgee is an open-source localization platform. Starting in version 3.14.0 and prior to version 3.23.1, when a request is made using an API key, the backend fails to verify the permission scopes associated with the key, effectively bypassing permission checks entirely for some endpoints. It's important to note that this vulnerability only affects projects that have inadvertently exposed their API keys on the internet. Projects that have kept their API keys secure are not impacted. This issue is fixed in version 3.23.1.
Affected configurations
• tolgee tolgee (>= 3.14.0 < 3.23.1)
Related
Weakness · CWE (1)
- CWE-862 Missing Authorization weakness
References
- https://github.com/tolgee/tolgee-platform/commit/4776cba67e7bb8c1b0259376e3e5fa3bb46e45c7 Patch
- https://github.com/tolgee/tolgee-platform/pull/1818 Patch
- https://github.com/tolgee/tolgee-platform/releases/tag/v3.23.1 Release Notes
- https://github.com/tolgee/tolgee-platform/security/advisories/GHSA-4f9j-4vh4-p85v Vendor Advisory
- https://github.com/tolgee/tolgee-platform/commit/4776cba67e7bb8c1b0259376e3e5fa3bb46e45c7 Patch
- https://github.com/tolgee/tolgee-platform/pull/1818 Patch
- https://github.com/tolgee/tolgee-platform/releases/tag/v3.23.1 Release Notes
- https://github.com/tolgee/tolgee-platform/security/advisories/GHSA-4f9j-4vh4-p85v Vendor Advisory