CVEvulnerability

CVE-2023-39441

5.9 MEDIUM Published 2023-08-23 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2023-08-23
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
5.9 MEDIUM — CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-295

Description

Apache Airflow SMTP Provider before 1.3.0, Apache Airflow IMAP Provider before 3.3.0, and Apache Airflow before 2.7.0 are affected by the Validation of OpenSSL Certificate vulnerability. The default SSL context with SSL library did not check a server's X.509 certificate.  Instead, the code accepted any certificate, which could result in the disclosure of mail server credentials or mail contents when the client connects to an attacker in a MITM position. Users are strongly advised to upgrade to Apache Airflow version 2.7.0 or newer, Apache Airflow IMAP Provider version 3.3.0 or newer, and Apache Airflow SMTP Provider version 1.3.0 or newer to mitigate the risk associated with this vulnerability

Affected configurations

• apache airflow (< 2.7.0) • apache apache-airflow-providers-imap (< 3.3.0) • apache apache-airflow-providers-smtp (< 1.3.0)

Related

Weakness · CWE (1)

  • CWE-295 Improper Certificate Validation weakness

References