CVEvulnerability
CVE-2023-40032
5.5 MEDIUM
Official page ↗
- Status
- Analyzed
- Published
- 2023-09-11
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 5.5 MEDIUM — CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- CVSS 3.1 ([email protected])
- 5.5 MEDIUM — CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-476
Description
libvips is a demand-driven, horizontally threaded image processing library. A specially crafted SVG input can cause libvips versions 8.14.3 or earlier to segfault when attempting to parse a malformed UTF-8 character. Users should upgrade to libvips version 8.14.4 (or later) when processing untrusted input.
Affected configurations
• fedoraproject fedora 39
• libvips libvips (>= 8.12.0 < 8.14.4)
Related
Weakness · CWE (1)
- CWE-476 NULL Pointer Dereference weakness
References
- https://github.com/libvips/libvips/commit/e091d65835966ef56d53a4105a7362cafdb1582b Patch
- https://github.com/libvips/libvips/pull/3604 Patch
- https://github.com/libvips/libvips/security/advisories/GHSA-33qp-9pq7-9584 Mitigation, Patch, Vendor Advisory
- https://lists.fedoraproject.org/archives/list/[email protected]/message/YU2FFC47X2XDEGEHEWAGLU5L3R6FEYD2/ Mailing List
- https://github.com/libvips/libvips/commit/e091d65835966ef56d53a4105a7362cafdb1582b Patch
- https://github.com/libvips/libvips/pull/3604 Patch
- https://github.com/libvips/libvips/security/advisories/GHSA-33qp-9pq7-9584 Mitigation, Patch, Vendor Advisory
- https://lists.fedoraproject.org/archives/list/[email protected]/message/YU2FFC47X2XDEGEHEWAGLU5L3R6FEYD2/ Mailing List