CVEvulnerability
CVE-2023-40033
7.1 HIGH
Official page ↗
- Status
- Modified
- Published
- 2023-08-16
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.1 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N
- CVSS 3.1 ([email protected])
- 7.1 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N
- Weaknesses
- CWE-918
Description
Flarum is an open source forum software. Flarum is affected by a vulnerability that allows an attacker to conduct a Blind Server-Side Request Forgery (SSRF) attack or disclose any file on the server, even with a basic user account on any Flarum forum. By uploading a file containing a URL and spoofing the MIME type, an attacker can manipulate the application to execute unintended actions. The vulnerability is due to the behavior of the `intervention/image` package, which attempts to interpret the supplied file contents as a URL, which then fetches its contents. This allows an attacker to exploit the vulnerability to perform SSRF attacks, disclose local file contents, or conduct a blind oracle attack. This has been patched in Flarum version 1.8.0. Users are advised to upgrade. Users unable to upgrade may disable PHP's `allow_url_fopen` which will prevent the fetching of external files via URLs as a temporary workaround for the SSRF aspect of the vulnerability.
Affected configurations
• flarum flarum (< 1.8.0)
Related
Weakness · CWE (1)
- CWE-918 Server-Side Request Forgery weakness
References
- https://github.com/flarum/framework/commit/d1059c1cc79fe61f9538f3da55e8f42abbede570 Patch
- https://github.com/flarum/framework/security/advisories/GHSA-67c6-q4j4-hccg Vendor Advisory
- https://github.com/flarum/framework/commit/d1059c1cc79fe61f9538f3da55e8f42abbede570 Patch
- https://github.com/flarum/framework/security/advisories/GHSA-67c6-q4j4-hccg Vendor Advisory