CVEvulnerability

CVE-2023-40313

8.8 HIGH Published 2023-08-17 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2023-08-17
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
7.1 HIGH — CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:L
CVSS 3.1 ([email protected])
8.8 HIGH — CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-94

Description

A BeanShell interpreter in remote server mode runs in OpenMNS Horizon versions earlier than 32.0.2 and in related Meridian versions which could allow arbitrary remote Java code execution. The solution is to upgrade to Meridian 2023.1.6, 2022.1.19, 2021.1.30, 2020.1.38 or Horizon 32.0.2 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.

Affected configurations

• opennms horizon (< 32.0.2) • opennms meridian (< 2020.1.38) • opennms meridian (>= 2021.1.0 < 2021.1.30) • opennms meridian (>= 2022.1.0 < 2022.1.19) • opennms meridian (>= 2023.1.0 < 2023.1.6)

Related

Weakness · CWE (1)

  • CWE-94 Improper Control of Generation of Code weakness

References