CVEvulnerability
CVE-2023-40588
6.5 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2023-09-15
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- CVSS 3.1 ([email protected])
- 6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-770
Description
Discourse is an open-source discussion platform. Prior to version 3.1.1 of the `stable` branch and version 3.2.0.beta1 of the `beta` and `tests-passed` branches, a malicious user could add a 2FA or security key with a carefully crafted name to their account and cause a denial of service for other users. The issue is patched in version 3.1.1 of the `stable` branch and version 3.2.0.beta1 of the `beta` and `tests-passed` branches. There are no known workarounds.
Affected configurations
• discourse discourse (< 3.1.1)
• discourse discourse 1.1.0
• discourse discourse 1.2.0
• discourse discourse 1.3.0
• discourse discourse 1.4.0
• discourse discourse 1.5.0
• discourse discourse 1.6.0
• discourse discourse 1.7.0
• discourse discourse 1.8.0
• discourse discourse 1.9.0
• discourse discourse 2.0.0
• discourse discourse 2.1.0
• discourse discourse 2.2.0
• discourse discourse 2.3.0
• discourse discourse 2.4.0
• discourse discourse 2.5.0
• discourse discourse 2.6.0
• discourse discourse 2.7.0
• discourse discourse 2.8.0
• discourse discourse 2.9.0
• discourse discourse 3.0.0
• discourse discourse 3.1.0
Related
Weakness · CWE (1)
- CWE-770 Allocation of Resources Without Limits or Throttling weakness
References
- https://github.com/discourse/discourse/security/advisories/GHSA-2hg5-3xm3-9vvx Third Party Advisory
- https://github.com/discourse/discourse/security/advisories/GHSA-2hg5-3xm3-9vvx Third Party Advisory