CVEvulnerability
CVE-2023-41057
5.5 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2023-09-04
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 5.5 MEDIUM — CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
- CVSS 3.1 ([email protected])
- 5.5 MEDIUM — CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
- Weaknesses
- CWE-22
Description
hyper-bump-it is a command line tool for updating the version in project files.`hyper-bump-it` reads a file glob pattern from the configuration file. That is combined with the project root directory to construct a full glob pattern that is used to find files that should be edited. These matched files should be contained within the project root directory, but that is not checked. This could result in changes being written to files outside of the project. The default behaviour of `hyper-bump-it` is to display the planned changes and prompt the user for confirmation before editing any files. However, the configuration file provides a field that can be used cause files to be edited without displaying the prompt. This issue has been fixed in release version 0.5.1. Users are advised to upgrade. Users that are unable to update from vulnerable versions, executing `hyper-bump-it` with the `--interactive` command line argument will ensure that all planned changes are displayed and prompt the user for confirmation before editing any files, even if the configuration file contains `show_confirm_prompt=true`.
Affected configurations
• plannigan hyper bump it (< 0.5.1)
Related
Weakness · CWE (1)
- CWE-22 Improper Limitation of a Pathname to a Restricted Directory weakness
References
- https://github.com/plannigan/hyper-bump-it/pull/307 Patch
- https://github.com/plannigan/hyper-bump-it/security/advisories/GHSA-xc27-f9q3-4448 Exploit, Patch, Vendor Advisory
- https://github.com/plannigan/hyper-bump-it/pull/307 Patch
- https://github.com/plannigan/hyper-bump-it/security/advisories/GHSA-xc27-f9q3-4448 Exploit, Patch, Vendor Advisory