CVEvulnerability
CVE-2023-41902
7.8 HIGH
Official page ↗
- Status
- Modified
- Published
- 2023-09-20
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.8 HIGH — CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-434
Description
An XPC misconfiguration vulnerability in CoreCode MacUpdater before 2.3.8, and 3.x before 3.1.2, allows attackers to escalate privileges by crafting malicious .pkg files.
Affected configurations
• corecode macupdater (< 2.3.8)
• corecode macupdater (>= 3.0.0 < 3.1.2)
Related
Weakness · CWE (1)
- CWE-434 Unrestricted Upload of File with Dangerous Type weakness
References
- https://gist.github.com/NSEcho/5d048a0796ceef59d6b1df1659bd1057 Third Party Advisory
- https://www.corecode.io/macupdater/history2.html Release Notes
- https://www.corecode.io/macupdater/history3.html Release Notes
- https://gist.github.com/NSEcho/5d048a0796ceef59d6b1df1659bd1057 Third Party Advisory
- https://www.corecode.io/macupdater/history2.html Release Notes
- https://www.corecode.io/macupdater/history3.html Release Notes