CVEvulnerability
CVE-2023-42460
7.5 HIGH
Official page ↗
- Status
- Modified
- Published
- 2023-09-27
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 5.3 MEDIUM — CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:H/A:N
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- Weaknesses
- CWE-682
Description
Vyper is a Pythonic Smart Contract Language for the EVM. The `_abi_decode()` function does not validate input when it is nested in an expression. Uses of `_abi_decode()` can be constructed which allow for bounds checking to be bypassed resulting in incorrect results. This issue has not yet been fixed, but a fix is expected in release `0.3.10`. Users are advised to reference pull request #3626.
Affected configurations
• vyperlang vyper (>= 0.3.4 < 0.3.10)
Related
Weakness · CWE (1)
- CWE-682 Incorrect Calculation weakness
References
- https://github.com/vyperlang/vyper/pull/3626 Patch
- https://github.com/vyperlang/vyper/security/advisories/GHSA-cx2q-hfxr-rj97 Exploit, Patch, Third Party Advisory
- https://github.com/vyperlang/vyper/pull/3626 Patch
- https://github.com/vyperlang/vyper/security/advisories/GHSA-cx2q-hfxr-rj97 Exploit, Patch, Third Party Advisory