CVEvulnerability

CVE-2023-43641

8.8 HIGH Published 2023-10-09 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2023-10-09
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 3.1 ([email protected])
8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weaknesses
CWE-787

Description

libcue provides an API for parsing and extracting data from CUE sheets. Versions 2.2.1 and prior are vulnerable to out-of-bounds array access. A user of the GNOME desktop environment can be exploited by downloading a cue sheet from a malicious webpage. Because the file is saved to `~/Downloads`, it is then automatically scanned by tracker-miners. And because it has a .cue filename extension, tracker-miners use libcue to parse the file. The file exploits the vulnerability in libcue to gain code execution. This issue is patched in version 2.3.0.

Affected configurations

• lipnitsk libcue (< 2.3.0) • fedoraproject fedora 37 • fedoraproject fedora 38 • fedoraproject fedora 39 • debian debian linux 10.0 • debian debian linux 11.0 • debian debian linux 12.0

Related

Weakness · CWE (1)

  • CWE-787 Out-of-bounds Write weakness

References