CVEvulnerability
CVE-2023-43659
5.4 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2023-10-16
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.0 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
- CVSS 3.1 ([email protected])
- 5.4 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
Description
Discourse is an open source platform for community discussion. Improper escaping of user input allowed for Cross-site Scripting attacks via the digest email preview UI. This issue only affects sites with CSP disabled. This issue has been patched in the 3.1.1 stable release as well as the 3.2.0.beta1 release. Users are advised to upgrade. Users unable to upgrade should ensure CSP is enabled on the forum.
Affected configurations
• discourse discourse (<= 3.1.1)
• discourse discourse 3.2.0
Related
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://developer.mozilla.org/en-US/docs/Web/HTTP/CSP Third Party Advisory
- https://github.com/discourse/discourse/security/advisories/GHSA-g4qg-5q2h-m8ph Vendor Advisory
- https://developer.mozilla.org/en-US/docs/Web/HTTP/CSP Third Party Advisory
- https://github.com/discourse/discourse/security/advisories/GHSA-g4qg-5q2h-m8ph Vendor Advisory