CVEvulnerability
CVE-2023-43668
9.8 CRITICAL
Official page ↗
- Status
- Modified
- Published
- 2023-10-16
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-639
Description
Authorization Bypass Through User-Controlled Key vulnerability in Apache InLong.This issue affects Apache InLong: from 1.4.0 through 1.8.0,
some sensitive params checks will be bypassed, like "autoDeserizalize","allowLoadLocalInfile"....
.
Users are advised to upgrade to Apache InLong's 1.9.0 or cherry-pick [1] to solve it.
[1] https://github.com/apache/inlong/pull/8604
Affected configurations
• apache inlong (>= 1.4.0 <= 1.8.0)
Related
Weakness · CWE (1)
- CWE-639 Authorization Bypass Through User-Controlled Key weakness
References
- https://lists.apache.org/thread/16gtk7rpdm1rof075ro83fkrnhbzn5sh Mailing List, Vendor Advisory
- https://lists.apache.org/thread/16gtk7rpdm1rof075ro83fkrnhbzn5sh Mailing List, Vendor Advisory