CVEvulnerability
CVE-2023-43770
CISA Known Exploited Vulnerability
Roundcube Webmail Persistent Cross-Site Scripting (XSS) Vulnerability — Roundcube Webmail
Roundcube Webmail contains a persistent cross-site scripting (XSS) vulnerability that can lead to information disclosure via malicious link references in plain/text messages.
- Added to KEV
- 2024-02-12
- Remediation due
- 2024-03-04
- Ransomware use
- Unknown
- Required action
- Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.
- Notes
- https://roundcube.net/news/2023/09/15/security-update-1.6.3-released ; https://nvd.nist.gov/vuln/detail/CVE-2023-43770
- Status
- Analyzed
- Published
- 2023-09-22
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 6.1 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 6.1 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
Description
Roundcube before 1.4.14, 1.5.x before 1.5.4, and 1.6.x before 1.6.3 allows XSS via text/plain e-mail messages with crafted links because of program/lib/Roundcube/rcube_string_replacer.php behavior.
Affected configurations
• roundcube webmail (< 1.4.14)
• roundcube webmail (>= 1.5.0 < 1.5.4)
• roundcube webmail (>= 1.6.0 < 1.6.3)
• debian debian linux 10.0
Related
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://github.com/roundcube/roundcubemail/commit/e92ec206a886461245e1672d8530cc93c618a49b Patch
- https://lists.debian.org/debian-lts-announce/2023/09/msg00024.html Mailing List
- https://roundcube.net/news/2023/09/15/security-update-1.6.3-released Release Notes
- https://github.com/roundcube/roundcubemail/commit/e92ec206a886461245e1672d8530cc93c618a49b Patch
- https://lists.debian.org/debian-lts-announce/2023/09/msg00024.html Mailing List
- https://roundcube.net/news/2023/09/15/security-update-1.6.3-released Release Notes
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2023-43770 US Government Resource