CVEvulnerability
CVE-2023-43795
9.8 CRITICAL
Official page ↗
- Status
- Modified
- Published
- 2023-10-25
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.6 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-918
Description
GeoServer is an open source software server written in Java that allows users to share and edit geospatial data. The OGC Web Processing Service (WPS) specification is designed to process information from any server using GET and POST requests. This presents the opportunity for Server Side Request Forgery. This vulnerability has been patched in version 2.22.5 and 2.23.2.
Affected configurations
• osgeo geoserver (< 2.22.5)
• osgeo geoserver (>= 2.23.0 < 2.23.2)
Related
Weakness · CWE (1)
- CWE-918 Server-Side Request Forgery weakness
References
- https://github.com/geoserver/geoserver/security/advisories/GHSA-5pr3-m5hm-9956 Mitigation, Vendor Advisory
- https://github.com/geoserver/geoserver/security/advisories/GHSA-5pr3-m5hm-9956 Mitigation, Vendor Advisory