CVEvulnerability
CVE-2023-43826
8.8 HIGH
Official page ↗
- Status
- Modified
- Published
- 2023-12-19
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
- CVSS 3.1 ([email protected])
- 8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-190
Description
Apache Guacamole 1.5.3 and older do not consistently ensure that values received from a VNC server will not result in integer overflow. If a user connects to a malicious or compromised VNC server, specially-crafted data could result in memory corruption, possibly allowing arbitrary code to be executed with the privileges of the running guacd process.
Users are recommended to upgrade to version 1.5.4, which fixes this issue.
Affected configurations
• apache guacamole (<= 1.5.3)
Related
Weakness · CWE (1)
- CWE-190 Integer Overflow or Wraparound weakness
References
- http://www.openwall.com/lists/oss-security/2023/12/19/4 Mailing List, Third Party Advisory
- https://lists.apache.org/thread/23gzwftpfgtq97tj6ttmbclry53kmwv6 Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2023/12/19/4 Mailing List, Third Party Advisory
- https://lists.apache.org/thread/23gzwftpfgtq97tj6ttmbclry53kmwv6 Mailing List, Vendor Advisory