CVEvulnerability

CVE-2023-4504

7.0 HIGH Published 2023-09-21 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2023-09-21
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
7.0 HIGH — CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
7.0 HIGH — CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
Weaknesses
CWE-122, CWE-787

Description

Due to failure in validating the length provided by an attacker-crafted PPD PostScript document, CUPS and libppd are susceptible to a heap-based buffer overflow and possibly code execution. This issue has been fixed in CUPS version 2.4.7, released in September of 2023.

Affected configurations

• openprinting cups (< 2.4.7) • openprinting libppd 2.0 • fedoraproject fedora 37 • fedoraproject fedora 38 • fedoraproject fedora 39 • debian debian linux 10.0

Related

Weakness · CWE (2)

  • CWE-122 Heap-based Buffer Overflow weakness
  • CWE-787 Out-of-bounds Write weakness

References