CVEvulnerability
CVE-2023-46118
4.9 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2023-10-25
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 4.9 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H
- CVSS 3.1 ([email protected])
- 4.9 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-400
Description
RabbitMQ is a multi-protocol messaging and streaming broker. HTTP API did not enforce an HTTP request body limit, making it vulnerable for denial of service (DoS) attacks with very large messages. An authenticated user with sufficient credentials can publish a very large messages over the HTTP API and cause target node to be terminated by an "out-of-memory killer"-like mechanism. This vulnerability has been patched in versions 3.11.24 and 3.12.7.
Affected configurations
• vmware rabbitmq (< 3.11.24)
• vmware rabbitmq (>= 3.12.0 < 3.12.7)
Related
Weakness · CWE (1)
- CWE-400 Uncontrolled Resource Consumption weakness
References
- https://github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-w6cq-9cf4-gqpg Vendor Advisory
- https://lists.debian.org/debian-lts-announce/2023/12/msg00009.html lists.debian.org
- https://www.debian.org/security/2023/dsa-5571 www.debian.org
- https://github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-w6cq-9cf4-gqpg Vendor Advisory
- https://lists.debian.org/debian-lts-announce/2023/12/msg00009.html lists.debian.org
- https://www.debian.org/security/2023/dsa-5571 www.debian.org