CVEvulnerability

CVE-2023-46131

7.5 HIGH Published 2023-12-21 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2023-12-21
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
CVSS 3.1 ([email protected])
7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-400

Description

Grails is a framework used to build web applications with the Groovy programming language. A specially crafted web request can lead to a JVM crash or denial of service. Any Grails framework application using Grails data binding is vulnerable. This issue has been patched in version 3.3.17, 4.1.3, 5.3.4, 6.1.0.

Affected configurations

• grails grails (< 3.3.17) • grails grails (>= 4.0.0 < 4.1.3) • grails grails (>= 5.0.0 < 5.3.4) • grails grails (>= 6.0.0 < 6.1.0)

Related

Weakness · CWE (1)

  • CWE-400 Uncontrolled Resource Consumption weakness

References