CVEvulnerability

CVE-2023-46724

7.5 HIGH Published 2023-11-01 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2023-11-01
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
8.6 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H
CVSS 3.1 ([email protected])
7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-125, CWE-1285, CWE-129, CWE-295, CWE-786, CWE-823

Description

Squid is a caching proxy for the Web. Due to an Improper Validation of Specified Index bug, Squid versions 3.3.0.1 through 5.9 and 6.0 prior to 6.4 compiled using `--with-openssl` are vulnerable to a Denial of Service attack against SSL Certificate validation. This problem allows a remote server to perform Denial of Service against Squid Proxy by initiating a TLS Handshake with a specially crafted SSL Certificate in a server certificate chain. This attack is limited to HTTPS and SSL-Bump. This bug is fixed in Squid version 6.4. In addition, patches addressing this problem for the stable releases can be found in Squid's patch archives. Those who you use a prepackaged version of Squid should refer to the package vendor for availability information on updated packages.

Affected configurations

• squid-cache squid (>= 3.3.0.1 < 6.4)

Related

Weakness · CWE (6)

  • CWE-125 Out-of-bounds Read weakness
  • CWE-1285 Improper Validation of Specified Index, Position, or Offset in Input weakness
  • CWE-129 Improper Validation of Array Index weakness
  • CWE-295 Improper Certificate Validation weakness
  • CWE-786 Access of Memory Location Before Start of Buffer weakness
  • CWE-823 Use of Out-of-range Pointer Offset weakness

References