CVEvulnerability
CVE-2023-46801
8.8 HIGH
Official page ↗
- Status
- Modified
- Published
- 2024-07-15
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-502
Description
In Apache Linkis <= 1.5.0, data source management module, when adding Mysql data source, exists remote code execution vulnerability for java version < 1.8.0_241. The deserialization vulnerability exploited through jrmp can inject malicious files into the server and execute them.
This attack requires the attacker to obtain an authorized account from Linkis before it can be carried out. We recommend that users upgrade the java version to >= 1.8.0_241. Or users upgrade Linkis to version 1.6.0.
Affected configurations
• apache linkis (>= 1.4.0 < 1.6.0)
Related
Weakness · CWE (1)
- CWE-502 Deserialization of Untrusted Data weakness
References
- https://lists.apache.org/thread/0dnzh64xy1n7qo3rgo2loz9zn7m9xgdx Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2024/07/13/6 www.openwall.com
- https://lists.apache.org/thread/0dnzh64xy1n7qo3rgo2loz9zn7m9xgdx Mailing List, Vendor Advisory