CVEvulnerability
CVE-2023-47037
4.3 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2023-11-12
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 4.3 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-863
Description
We failed to apply CVE-2023-40611 in 2.7.1 and this vulnerability was marked as fixed then.
Apache Airflow, versions before 2.7.3, is affected by a vulnerability that allows authenticated and DAG-view authorized Users to modify some DAG run detail values when submitting notes. This could have them alter details such as configuration parameters, start date, etc.
Users should upgrade to version 2.7.3 or later which has removed the vulnerability.
Affected configurations
• apache airflow (< 2.7.3)
Related
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness
References
- http://www.openwall.com/lists/oss-security/2023/11/12/1 Mailing List, Third Party Advisory
- https://github.com/apache/airflow/pull/33413 Issue Tracking, Patch
- https://lists.apache.org/thread/04y4vrw1t2xl030gswtctc4nt1w90cb0 Mailing List
- http://www.openwall.com/lists/oss-security/2023/11/12/1 Mailing List, Third Party Advisory
- https://github.com/apache/airflow/pull/33413 Issue Tracking, Patch
- https://lists.apache.org/thread/04y4vrw1t2xl030gswtctc4nt1w90cb0 Mailing List