CVEvulnerability
CVE-2023-47121
9.8 CRITICAL
Official page ↗
- Status
- Modified
- Published
- 2023-11-10
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 3.4 LOW — CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:N/A:N
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-918
Description
Discourse is an open source platform for community discussion. Prior to version 3.1.3 of the `stable` branch and version 3.2.0.beta3 of the `beta` and `tests-passed` branches, the embedding feature is susceptible to server side request forgery. The issue is patched in version 3.1.3 of the `stable` branch and version 3.2.0.beta3 of the `beta` and `tests-passed` branches. As a workaround, disable the Embedding feature.
Affected configurations
• discourse discourse (< 3.1.3)
• discourse discourse (< 3.2.0)
• discourse discourse 3.2.0
Related
Weakness · CWE (1)
- CWE-918 Server-Side Request Forgery weakness
References
- https://github.com/discourse/discourse/commit/24cca10da731734af4e9748de99a508d586e59f1 Patch
- https://github.com/discourse/discourse/commit/5f20748e402223b265e6fee381472c14e2604da6 Patch
- https://github.com/discourse/discourse/security/advisories/GHSA-hp24-94qf-8cgc Vendor Advisory
- https://github.com/discourse/discourse/commit/24cca10da731734af4e9748de99a508d586e59f1 Patch
- https://github.com/discourse/discourse/commit/5f20748e402223b265e6fee381472c14e2604da6 Patch
- https://github.com/discourse/discourse/security/advisories/GHSA-hp24-94qf-8cgc Vendor Advisory