CVEvulnerability
CVE-2023-48291
4.3 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2023-12-21
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 4.3 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-668
Description
Apache Airflow, in versions prior to 2.8.0, contains a security vulnerability that allows an authenticated user with limited access to some DAGs, to craft a request that could give the user write access to various DAG resources for DAGs that the user had no access to, thus, enabling the user to clear DAGs they shouldn't.
This is a missing fix for CVE-2023-42792 in Apache Airflow 2.7.2
Users of Apache Airflow are strongly advised to upgrade to version 2.8.0 or newer to mitigate the risk associated with this vulnerability.
Affected configurations
• apache airflow (< 2.8.0)
Related
Weakness · CWE (1)
- CWE-668 Exposure of Resource to Wrong Sphere weakness
References
- http://www.openwall.com/lists/oss-security/2023/12/21/1 Mailing List, Third Party Advisory
- https://github.com/apache/airflow/pull/34366 Patch
- https://lists.apache.org/thread/3nl0h014274yjlt1hd02z0q78ftyz0z3 Mailing List, Third Party Advisory
- http://www.openwall.com/lists/oss-security/2023/12/21/1 Mailing List, Third Party Advisory
- https://github.com/apache/airflow/pull/34366 Patch
- https://lists.apache.org/thread/3nl0h014274yjlt1hd02z0q78ftyz0z3 Mailing List, Third Party Advisory