CVEvulnerability
CVE-2023-48699
9.8 CRITICAL
Official page ↗
- Status
- Modified
- Published
- 2023-11-21
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.4 HIGH — CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-94, CWE-95
Description
fastbots is a library for fast bot and scraper development using selenium and the Page Object Model (POM) design. Prior to version 0.1.5, an attacker could modify the locators.ini locator file with python code that without proper validation it's executed and it could lead to rce. The vulnerability is in the function `def __locator__(self, locator_name: str)` in `page.py`. In order to mitigate this issue, upgrade to fastbots version 0.1.5 or above.
Affected configurations
• ubertidavide fastbots (< 0.1.5)
Related
References
- https://github.com/ubertidavide/fastbots/commit/73eb03bd75365e112b39877e26ef52853f5e9f57 Patch
- https://github.com/ubertidavide/fastbots/pull/3#issue-2003080806 Issue Tracking, Patch
- https://github.com/ubertidavide/fastbots/security/advisories/GHSA-vccg-f4gp-45x9 Exploit, Vendor Advisory
- https://github.com/ubertidavide/fastbots/commit/73eb03bd75365e112b39877e26ef52853f5e9f57 Patch
- https://github.com/ubertidavide/fastbots/pull/3#issue-2003080806 Issue Tracking, Patch
- https://github.com/ubertidavide/fastbots/security/advisories/GHSA-vccg-f4gp-45x9 Exploit, Vendor Advisory