CVEvulnerability
CVE-2023-49099
4.3 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2024-01-12
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 3.1 LOW — CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:N
- CVSS 3.1 ([email protected])
- 4.3 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N
- Weaknesses
- CWE-284
Description
Discourse is a platform for community discussion. Under very specific circumstances, secure upload URLs associated with posts can be accessed by guest users even when login is required. This vulnerability has been patched in 3.2.0.beta4 and 3.1.4.
Affected configurations
• discourse discourse (< 3.1.4)
• discourse discourse 3.2.0
Related
Weakness · CWE (1)
- CWE-284 Improper Access Control weakness
References
- https://github.com/discourse/discourse/commit/1b288236387fc0a823e4f15f1aea8dde81b49d53 Patch
- https://github.com/discourse/discourse/security/advisories/GHSA-j67x-x6mq-pwv4 Vendor Advisory
- https://github.com/discourse/discourse/commit/1b288236387fc0a823e4f15f1aea8dde81b49d53 Patch
- https://github.com/discourse/discourse/security/advisories/GHSA-j67x-x6mq-pwv4 Vendor Advisory