CVEvulnerability
CVE-2023-49213
8.8 HIGH
Official page ↗
- Status
- Modified
- Published
- 2023-11-23
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-77
Description
The API endpoints in Ironman PowerShell Universal 3.0.0 through 4.2.0 allow remote attackers to execute arbitrary commands via crafted HTTP requests if a param block is used, due to invalid sanitization of input strings. The fixed versions are 3.10.2, 4.1.10, and 4.2.1.
Affected configurations
• ironmansoftware powershell universal (>= 3.0.0 < 3.10.2)
• ironmansoftware powershell universal (>= 4.1.0 < 4.1.10)
• ironmansoftware powershell universal 4.2.0
Related
Weakness · CWE (1)
- CWE-77 Improper Neutralization of Special Elements used in a Command weakness
References
- https://blog.ironmansoftware.com/powershell-universal-apis-cve/ Exploit, Mitigation, Vendor Advisory
- https://docs.powershelluniversal.com/changelogs/changelog Release Notes
- https://blog.ironmansoftware.com/powershell-universal-apis-cve/ Exploit, Mitigation, Vendor Advisory
- https://docs.powershelluniversal.com/changelogs/changelog Release Notes