CVEvulnerability
CVE-2023-49299
8.8 HIGH
Official page ↗
- Status
- Modified
- Published
- 2023-12-30
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-20
Description
Improper Input Validation vulnerability in Apache DolphinScheduler. An authenticated user can cause arbitrary, unsandboxed javascript to be executed on the server.This issue affects Apache DolphinScheduler: until 3.1.9.
Users are recommended to upgrade to version 3.1.9, which fixes the issue.
Affected configurations
• apache dolphinscheduler (< 3.1.9)
Related
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- http://www.openwall.com/lists/oss-security/2024/02/23/3 www.openwall.com
- https://github.com/apache/dolphinscheduler/pull/15228 Patch, Vendor Advisory
- https://lists.apache.org/thread/tnf99qoc6tlnwrny4t1zk6mfszgdsokm Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2024/02/23/3 www.openwall.com
- https://github.com/apache/dolphinscheduler/pull/15228 Patch, Vendor Advisory
- https://lists.apache.org/thread/tnf99qoc6tlnwrny4t1zk6mfszgdsokm Mailing List, Vendor Advisory