CVEvulnerability
CVE-2023-50709
7.5 HIGH
Official page ↗
- Status
- Modified
- Published
- 2023-12-13
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-20
Description
Cube is a semantic layer for building data applications. Prior to version 0.34.34, it is possible to make the entire Cube API unavailable by submitting a specially crafted request to a Cube API endpoint. The issue has been patched in `v0.34.34` and it's recommended that all users exposing Cube APIs to the public internet upgrade to the latest version to prevent service disruption.
There are currently no workaround for older versions, and the recommendation is to upgrade.
Affected configurations
• cube cube.js (< 0.34.34)
Related
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://github.com/cube-js/cube/releases/tag/v0.34.34 Release Notes
- https://github.com/cube-js/cube/security/advisories/GHSA-9759-3276-g2pm Third Party Advisory
- https://github.com/cube-js/cube/releases/tag/v0.34.34 Release Notes
- https://github.com/cube-js/cube/security/advisories/GHSA-9759-3276-g2pm Third Party Advisory