CVEvulnerability

CVE-2023-50783

6.5 MEDIUM Published 2023-12-21 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2023-12-21
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
Weaknesses
CWE-284

Description

Apache Airflow, versions before 2.8.0, is affected by a vulnerability that allows an authenticated user without the variable edit permission, to update a variable. This flaw compromises the integrity of variable management, potentially leading to unauthorized data modification. Users are recommended to upgrade to 2.8.0, which fixes this issue

Affected configurations

• apache airflow (< 2.8.0)

Related

Weakness · CWE (1)

  • CWE-284 Improper Access Control weakness

References