CVEvulnerability

CVE-2023-51379

4.9 MEDIUM Published 2023-12-21 Modified 2026-06-17 Official page ↗
Status
Analyzed
Published
2023-12-21
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
4.9 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:N
CVSS 3.1 ([email protected])
4.9 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:N
Weaknesses
CWE-863

Description

An incorrect authorization vulnerability was identified in GitHub Enterprise Server that allowed issue comments to be updated with an improperly scoped token. This vulnerability did not allow unauthorized access to any repository content as it also required contents:write and issues:read permissions. This vulnerability affected all versions of GitHub Enterprise Server since 3.7 and was fixed in version 3.17.19, 3.8.12, 3.9.7, 3.10.4, and 3.11.1. 

Affected configurations

• github enterprise server (>= 3.7.0 < 3.7.19) • github enterprise server (>= 3.8.0 < 3.8.12) • github enterprise server (>= 3.9.0 < 3.9.7) • github enterprise server (>= 3.10.0 < 3.10.4) • github enterprise server 3.11.0

Related

Weakness · CWE (1)

  • CWE-863 Incorrect Authorization weakness

References