CVEvulnerability
CVE-2023-5664
5.4 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2023-11-22
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 6.4 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- CVSS 3.1 ([email protected])
- 5.4 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
Description
The Garden Gnome Package plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'ggpkg' shortcode in all versions up to, and including, 2.2.8 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This was partially patched in version 2.2.7 and fully patched in version 2.2.9.
Affected configurations
• ggnome garden gnome package (< 2.2.9)
Related
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://plugins.trac.wordpress.org/browser/garden-gnome-package/tags/2.2.5/include/ggpackage.php#L284 Patch
- https://plugins.trac.wordpress.org/changeset/2987987/garden-gnome-package#file1 Patch
- https://plugins.trac.wordpress.org/changeset/2988944/garden-gnome-package#file1 Patch
- https://www.wordfence.com/threat-intel/vulnerabilities/id/8c7385c7-47de-4511-b474-7415c3977aa8?source=cve Third Party Advisory
- https://plugins.trac.wordpress.org/browser/garden-gnome-package/tags/2.2.5/include/ggpackage.php#L284 Patch
- https://plugins.trac.wordpress.org/changeset/2987987/garden-gnome-package#file1 Patch
- https://plugins.trac.wordpress.org/changeset/2988944/garden-gnome-package#file1 Patch
- https://www.wordfence.com/threat-intel/vulnerabilities/id/8c7385c7-47de-4511-b474-7415c3977aa8?source=cve Third Party Advisory