CVEvulnerability

CVE-2023-6804

5.5 MEDIUM Published 2023-12-21 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2023-12-21
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
6.5 MEDIUM — CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:L
CVSS 3.1 ([email protected])
5.5 MEDIUM — CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
Weaknesses
CWE-269

Description

Improper privilege management allowed arbitrary workflows to be committed and run using an improperly scoped PAT. To exploit this, a workflow must have already existed in the target repo. This vulnerability affected all versions of GitHub Enterprise Server since 3.8 and was fixed in version 3.8.12, 3.9.7, 3.10.4, and 3.11.1.

Affected configurations

• github enterprise server (>= 3.8.0 < 3.8.12) • github enterprise server (>= 3.9.0 < 3.9.7) • github enterprise server (>= 3.10.0 < 3.10.4) • github enterprise server 3.11.0

Related

Weakness · CWE (1)

  • CWE-269 Improper Privilege Management weakness

References